한국어English日本語简体中文繁體中文DeutschไทยTiếng ViệtРусскийPortuguês (Brasil)EspañolBahasa Indonesia

Game-Lag-Whitepaper › L5 Netzwerkgeräte im Rechenzentrum

Vollauslastung der Rechenzentrumsanbindung Uplink saturation

Ursachen-ID dc-uplink · Hauptzuständig Netzwerk-Infrastruktur (Infrastrukturteam) · Beteiligt Server-Infrastruktur (Infrastrukturteam)

In der interaktiven Fassung mit Grafiken und Experimenten öffnen →

Nutzen Patch-Verteilung, Log-Übertragung oder Backups dieselbe Leitung wie das Spiel, läuft die Leitung voll.

Warum Große Übertragungen belegen dieselbe Leitung → Folge Warteschlange und Paketverlust auf der Leitung steigen → Auf dem Bildschirm Höherer Ping und Teleportieren auf dem ganzen Server

Symptome
Input-Lag, Teleportieren
Faktoren
Latenz, Paketverlust
Wer ist betroffen
Ganzer Server
Wann
In festen Abständen, Bei großem Andrang
Zuständigkeit
Hauptzuständig Netzwerk-Infrastruktur (Infrastrukturteam) · Beteiligt Server-Infrastruktur (Infrastrukturteam)
Aufgaben Infrastrukturteam
Netzwerk: Spiel-Traffic priorisieren (QoS), große Übertragungen auf eine eigene Leitung legen, Alarm auf die Leitungsauslastung. Server/OS: Backups, Log-Übertragung und Deployments drosseln und zu ruhigen Zeiten ausführen.
Im Graphen
Plateau am Limit · Leitungsauslastung, RTT (Ping)
Wo nachsehen
Auslastung (berechnet aus SNMP ifHCInOctets und ifHCOutOctets) und Ausgangsdrops (ifOutDiscards) am Interface der Rechenzentrumsanbindung (Uplink) auf dieselbe Zeitachse legen wie die Zeitpläne für Backups, Deployments und Log-Übertragungen
Spricht dafür
Sobald die Leitungsauslastung flach an der Bandbreitengrenze anliegt, steigen RTT und Drops auf dem ganzen Server, und dieser Zeitpunkt fällt mit großen Übertragungsjobs zusammen
Spricht dagegen
Auslastung im Minutenmittel weit unter dem Limit, trotzdem Drops: „Microbursts am Switch“
Prüfmittel
Mit Infrastruktur-Tools prüfbar (ohne Spielcode)

Quellen

  1. RFC 4594: Configuration Guidelines for DiffServ Service Classes IETF
    Interaktiven Echtzeit-Traffic wie Spiele und große Übertragungen wie Backups in getrennten Serviceklassen behandeln
  2. RFC 7567: IETF Recommendations Regarding Active Queue Management IETF
    Kommt mehr in ein Gerät hinein, als es ausgeben kann, bilden sich Warteschlangen, übermäßige Warteschlangen sind eine Hauptursache für Latenz
  3. RFC 2863: The Interfaces Group MIB IETF
    ifHCInOctets, ifHCOutOctets: über das Interface empfangene bzw. gesendete Bytes (64 Bit), ifOutDiscards: Zahl der Pakete, die nicht gesendet werden konnten und verworfen wurden

Verwandte Ursachen

Gleiche Schicht: L5 Netzwerkgeräte im Rechenzentrum

Ursachen aus anderen Schichten mit demselben Symptom (Input-Lag)

Karte in der interaktiven Fassung mit Grafiken und Experimenten ansehen