คู่มือเกมแลค › L5 อุปกรณ์เครือข่ายในดาต้าเซ็นเตอร์
ลิงก์ของดาต้าเซ็นเตอร์เต็ม Uplink saturation
ID สาเหตุ dc-uplink · ผู้รับผิดชอบหลัก อินฟราเครือข่าย (ทีมอินฟรา) · ร่วมกับ อินฟราเซิร์ฟเวอร์ (ทีมอินฟรา)
เปิดการ์ดในฉบับหลักที่มีภาพและการทดลอง →
ถ้าการแจกจ่ายแพตช์ การส่ง log หรือการสำรองข้อมูล ใช้ลิงก์เดียวกับเกม ลิงก์จะเต็ม
ทำไม การส่งข้อมูลขนาดใหญ่กินลิงก์เดียวกัน → ผลคือ คิวในลิงก์และแพ็กเก็ตหายเพิ่มขึ้น → บนหน้าจอ ปิงสูงขึ้นทั้งเซิร์ฟเวอร์และวาร์ป
- อาการ
- อินพุตดีเลย์, วาร์ป
- ปัจจัย
- ความหน่วง, แพ็กเก็ตหาย
- ใครเจอ
- ทั้งเซิร์ฟเวอร์
- เกิดเมื่อไร
- เป็นรอบสม่ำเสมอ, ตอนคนแห่มารวมกัน
- ผู้รับผิดชอบ
- ผู้รับผิดชอบหลัก อินฟราเครือข่าย (ทีมอินฟรา) · ร่วมกับ อินฟราเซิร์ฟเวอร์ (ทีมอินฟรา)
- งานฝั่งทีมอินฟรา
- เครือข่าย: ให้ความสำคัญกับทราฟฟิกเกมก่อน (QoS), แยกลิงก์สำหรับส่งข้อมูลขนาดใหญ่, ตั้ง alert อัตราการใช้งานลิงก์ เครื่องเซิร์ฟเวอร์/OS: จำกัดความเร็วการสำรองข้อมูล การส่ง log และการ deploy แล้วรันในช่วงที่คนน้อย
- บนกราฟ
- ชนเพดานแล้วแบนราบ · อัตราการใช้งานลิงก์, RTT (ปิง)
- จุดที่ต้องดู
- วางอัตราการใช้งาน (คำนวณจาก SNMP ifHCInOctets และ ifHCOutOctets) และการทิ้งขาออก (ifOutDiscards) ของอินเทอร์เฟซลิงก์ดาต้าเซ็นเตอร์ (uplink) ไว้บนแกนเวลาเดียวกับตารางการสำรองข้อมูล การ deploy และการส่ง log
- สัญญาณว่าใช่
- ในเวลาที่อัตราการใช้งานลิงก์ชนขีดจำกัดแบนด์วิดท์จนแบนราบ RTT ของทั้งเซิร์ฟเวอร์และการทิ้งสูงขึ้น และเวลานั้นตรงกับงานส่งข้อมูลขนาดใหญ่
- สัญญาณว่าไม่ใช่
- ถ้าอัตราการใช้งานระดับนาทียังห่างจากขีดจำกัดมากแต่มีการทิ้ง น่าจะเป็น “microburst ที่สวิตช์”
- วิธีตรวจ
- ใช้เครื่องมือฝั่งอินฟรา (ไม่ต้องใช้โค้ดเกม)
แหล่งอ้างอิง
- RFC 4594: Configuration Guidelines for DiffServ Service Classes IETF
แยกทราฟฟิกแบบโต้ตอบเรียลไทม์อย่างเกม กับการส่งข้อมูลขนาดใหญ่อย่างการสำรองข้อมูล ไว้คนละ service class - RFC 7567: IETF Recommendations Regarding Active Queue Management IETF
ถ้าข้อมูลที่เข้ามาในอุปกรณ์มากกว่าความเร็วที่ส่งออกได้ คิวจะสะสม และคิวที่มากเกินไปเป็นสาเหตุหลักของความหน่วง - RFC 2863: The Interfaces Group MIB IETF
ifHCInOctets และ ifHCOutOctets: จำนวนไบต์ที่อินเทอร์เฟซรับและส่ง (64 บิต), ifOutDiscards: จำนวนแพ็กเก็ตที่ส่งออกไม่ได้และถูกทิ้ง
สาเหตุที่ควรดูประกอบ
ชั้นเดียวกัน: L5 อุปกรณ์เครือข่ายในดาต้าเซ็นเตอร์
สาเหตุจากชั้นอื่นที่ทำให้เกิดอาการเดียวกัน (อินพุตดีเลย์)
ดูการ์ดในฉบับหลักที่มีภาพและการทดลอง